threads
Page 1 of 1
Engine \  engine running like shit

engine running like shit

Engine Isuzu Tech
views 779
replies 5
following 4
 
rangerdanger avatar
rangerdanger   +1y
hey guys, i got a 94 pup. its the 2.3 carb motor. I CANNOT get this thing to idle right. ive replaced vacumm lines, cleaned the carb, ran cleaner thru it, new plugs, oil changes, air filters. Ive adjusted it over and over, and tried everything i can on it to get it to just idle right.

Can anyone help me, or tell me what i might need or dont need. Just to get this thing runnin good.

It idles from 1 to 2000 after i drive it for a little while, back and forth, 1,2,1,2,1,2, and sometimes itll idle at 600 and just barely wants to die. I dunno.
isuzueh avatar
isuzueh   +1y
sounds like a crank sensor?? if isuzu's are equiped with them...my jeep did that and it was the crank sensor
rangerdanger avatar
rangerdanger   +1y
crank sensor eh...weres that located, if it has one??
perfectlywicked avatar
perfectlywicked   +1y
sounds like you have carb problems the 2.3 is known for that thats why most people go with the weber carbs
eatinpavement avatar
eatinpavement   +1y
its probably the intake manifold gasket. thats a common problem on these trucks. i've had it with all of the zu's ive owned. to check it let the truck idle and spray some carb cleaner around where the intake meets the head if idle picks up then theres your problem. the gaskets leaking making the intake lose vaccum.
eatinpavement avatar
eatinpavement   +1y
any progress?
Page 1 of 1