Chevy/GMC Trucks
Genres:  
All Genre's  


s10 pass lock system?



Zach Eslinger

 
Joined: 8/8/2005
Posted 7/19/2010 via Website

Edit Thread

Title:
Caption:

i bought a 98 s10 for a beater was havin trouble getting it to start. I replaced the fuelpump and nothing it still doesnt work.... i was told about the passlock security system might be causing this? anyone know about this....it has me beyond fucking frustrated to the point of wanting to just sendt the truck to the junkyard.
brian stubblefield

 
Joined: 1/29/2007
Posted 7/19/2010 via Website

Edit Thread

Title:
Caption:

hey man, i had this happen to my project and it pissed me off to no end. try and see if this works for you. its time consuming but it did end up working out perfectly after a few times. *FOLLOW THEM EXACTLY* 1. First, insert the ignition key andturn the ignition switch to the“On” position (Do not start theengine). Leave the switch on for11 minutes. The security lightmay flash or be on steady duringthis 11 minute period. Make surethe light is no longer on orflashing before proceeding to #2 .2. Turn the ignition switch off for 30seconds.3. Turn the ignition switch to the“On” position (as in step #1) for11 minutes again.4. Turn the ignition switch off foranother 30 seconds.5. Turn the ignition switch to the“On” position for 11 minutes athird time.6. Turn the ignition switch off for 30seconds one final time.7. Turn the ignition switch to the“On” position one final time andwait 30 seconds.8. Attempt to start the engine.If the engine starts and runsnormally, the relearn iscomplete. *OR* GM PASS LOCK RELEARN- Ignition to "run" position, try to start and let key return to "run" position Approx ten minutes security light will go off Turn key "off" and wait 5 seconds Repeat 2 more times for a total of 3 relearns. Turn key off, then start it If this doesnt work, we need to test the crank sensor, they are cheap about 20.00 bucks, but if there is no crank signal, injectors are dissabled, gas prayed into the throttle body will bypass injectors, so gas is getting to the clyinders that way... *OR*GM PASS LOCK RELEARN- Ignition to "run" position, try to start and let key return to "run" position Approx ten minutes security light will go off Turn key "off" and wait 5 seconds after turning the key off, the SECURITY light went off, YEAH....Repeat 2 more times for a total of 3 relearns. Turn key off, then start it........................................
Zach Eslinger

 
Joined: 8/8/2005
Posted 7/19/2010 via Website

Edit Thread

Title:
Caption:

damn dud.......you are the man.....ill try this tomorrow after work. thanks alot!
HollywoodFMX

 
Joined: 9/13/2010
Posted 9/14/2010 via Website

Edit Thread

Title:
Caption:

its funny i stumbled across this cuz im kinda havin the same damn issue... ive gone thru all the fuses and relays, even the four relays stashed under the dash that isnt even in the manual... ive replaced the ignition switch(wiring, not the key and tumblers), and gone thru a lot of wiring checks... after taking the four relays under the dash out and checking them one at a time, i put the last one back in and i started the truck up and everything was working great... i put the dash back together and and went to start it and absolutly nothing! it was back to square one for me. im down to thinking that its the security thing but my security light isnt on. that or its a wire shorting out somewhere under the dash, and got fixed when i moved the relay panel and shorted out again when i moved it back... cuz one of those relays was clicking on as soon as i plugged it in and got pretty hot just from being plugged in... it wasnt labeled so i dont know wat its for.... and wiring really sux when your color blind!!! ill deffinetly give that relearn thing a try!
James McDowell

 
Joined: 7/17/2003
Posted 9/14/2011 via Website

Edit Thread

Title:
Caption:

This thread is exactly one year old today, and im having the same problem, only a little different. Last time I worked on my S10 was about 4 months ago. 4 months ago the truck started fine, no problems. So today I go to work on my truck, and my battery has died, so I went and got it charged. Just put it in and tried to start my S10. It just cranks fine just doesn't start and the Security Light just stays "ON", no flashing, just ON.. and t has been on for the last 45 minutes. Ive done the relearn procedure before and it works like a charm, just in this case my SECURITY light will not go out.. i don't know what to do. I just pulled out the tumbler all the contacts look good, reinstalled it and the truck has been ON for 25 minutes and the Security light is still lit?? Any thoughts on this??
Jack Frith

 
Joined: 6/28/2009
Posted 9/14/2011 via Website

Edit Thread

Title:
Caption:

just get the passlock removed. that's what i did.
James McDowell

 
Joined: 7/17/2003
Posted 9/14/2011 via Website

Edit Thread

Title:
Caption:

How did you go about removing the passlock?
James McDowell

 
Joined: 7/17/2003
Posted 9/15/2011 via Website

Edit Thread

Title:
Caption:

Bump.. anybody else have some input on this issue?? Super Frustrated right now..
Ian Siadak

 
Joined: 9/17/2000
Posted 9/16/2011 via Website

Edit Thread

Title:
Caption:

when I worked at a car audio shop we called the dealer on one and they said to just pull the neg. off the battery turn the key to run and put the negative back on. It would work almost every time.
Jack Frith

 
Joined: 6/28/2009
Posted 9/16/2011 via Website

Edit Thread

Title:
Caption:

if you want to know how to remove passlock text me. 661-205-7336. dont have time to type it all out on here right now.
James McDowell

 
Joined: 7/17/2003
Posted 9/16/2011 via Website

Edit Thread

Title:
Caption:

lowazzmaz - Thanks for the help man.. I'm going to try that the next day I'm off.. Laidoutvideo - Text sent.. I'll Keep y'all posted
rangerover8586

 
Joined: 11/26/2004
Posted 9/17/2011 via Website

Edit Thread

Title:
Caption:

my 98 did the same thing i tried having dealer reflash and everythign ended up haveing to put a new computer in it after i had already put in a new $300 fuel pump and countless hours trying to figure it out
James McDowell

 
Joined: 7/17/2003
Posted 9/18/2011 via Website

Edit Thread

Title:
Caption:

So lowazzmaz you were right. Removing the negative cable, turning the ignition to ON and reconnecting the negative cable, cleared the Security light, but as soon as I turn the Key to crank the motor the Security light comes right back on and kills the fuel system. Back to square one. rangerover8586 you say you just bought a new computer and solved the issue? might have to look into that. You just have to find one with a matching VIN correct? Laidoutvideo mentioned to have the Passlock removed from the PCM, also going to look into that. Going at it full bore tomorrow, so hopefully I will be successful. Again I appreciate the Help fellas!
James McDowell

 
Joined: 7/17/2003
Posted 9/21/2011 via Website

Edit Thread

Title:
Caption:

Ok so I sent my PCM out to Wait4meperformance to have them remove the Passlock feature and give it a little performance tune.. Big thanks to LaidOutVideo for helping me out on this!!
Jack Frith

 
Joined: 6/28/2009
Posted 9/25/2011 via Website

Edit Thread

Title:
Caption:

No problem man. I know first hand how frustrating it can be. Let me know when u get ur PCM back.
James McDowell

 
Joined: 7/17/2003
Posted 11/7/2011 via Website

Edit Thread

Title:
Caption:

Ok, so I literally just solved MY problem.. a new fuel pump was the issue.. so with the new pump installed, my dime fired right up on the 2nd crank!!! Soo Stoked right now!!!
matt goodwin

 
Joined: 5/3/2005
Posted 11/9/2011 via Website

Edit Thread

Title:
Caption:

Ok I have literally tried all of these and nothing is working. Mine starts and runs for about 2 seconds then dies. Myself and a few other people have tried everything we can think of. Any ideas?? Please HELP lol
matt goodwin

 
Joined: 5/3/2005
Posted 11/10/2011 via Website

Edit Thread

Title:
Caption:

Bump.
James McDowell

 
Joined: 7/17/2003
Posted 11/10/2011 via Website

Edit Thread

Title:
Caption:

Maybe send your Computer to Wait For Me Performance.. it cost me $88, if you have tried everything else and you are sure your grounds are all good, and in my case your fuel pump is working correctly, drop him a line. Double, triple check ALL of your fuses. If you send your computer tell him you want to delete the passlock. Hope this helps, keep us posted.
James McDowell

 
Joined: 7/17/2003
Posted 3/26/2012 via Website

Edit Thread

Title:
Caption:

Welp, back at it.. and guess what.. my truck wont start, AGAIN. The last time I went through this I had to replace the fuel pump, so my question now is, can a fuel pump go bad just from sitting?? the last time I started the truck was January, every thing was good, cranked fine. Removed the battery for some work and kept it out, threw it in today and, NO-GO. I shouldn't have to replace the fuel pump every time should I? seems ridiculous. going through the Pass Lock Re-learn right now, hope that solves it.
brian stubblefield

 
Joined: 1/29/2007
Posted 3/26/2012 via Website

Edit Thread

Title:
Caption:

just parking the truck souldnt have these problems. once the pass-lock has been "re-learned" it will retain it even if the battery is removed. when you turn the key, do you hear the fuel pump kick on? that 3-5 second humm? if your not hearing that humm, its the fuel pump but if you do hear it and it fires but dies, its the injectors being shut off because the computer is 'THINKING" its being stolen.
style="width:500px">



Close
Close